Issue accessing accounts in the US region

Incident Report for Good Grants

Resolved

The issue affecting US regions has been resolved.
Posted Mar 16, 2026 - 19:09 UTC

Monitoring

Access to US accounts has been restored however performance may still be degraded. We continue to monitor and investigate the issue.
Posted Mar 16, 2026 - 17:47 UTC

Investigating

We are currently investigating an issue accessing accounts in the US region.
Posted Mar 16, 2026 - 17:10 UTC
This incident affected: Good Grants application.