Known issues with accounts based in EU region
Incident Report for Good Grants
Resolved
The issue has been resolved, thank you for your patience.
Posted Mar 28, 2024 - 15:05 UTC
Identified
We are aware some accounts based in the EU region are unable to access their program. We have already identified the root cause and are working towards a resolution as a top priority. Thank you for your patience and understanding.
Posted Mar 28, 2024 - 14:54 UTC
This incident affected: Good Grants application.