UAE accounts impacted

Incident Report for Good Grants

Update

We are continuing to monitor for any further issues.
Posted Mar 04, 2026 - 14:14 UTC

Monitoring

Good Grants accounts hosted in the UAE are temporarily offline due to regional infrastructure disruption. Affected clients have been contacted directly. All other accounts are operating normally.
Posted Mar 04, 2026 - 14:09 UTC