**Issue affecting US based accounts only**
Incident Report for Good Grants
Resolved
We have now resolved the homepage loading issue. Thank you for your patience.
Posted Nov 20, 2023 - 15:18 UTC
Investigating
We are aware of an issue affecting US accounts—most of the elements on the homepage are not loading. This is currently being investigated as a matter of urgency by the engineering team.
Posted Nov 20, 2023 - 14:31 UTC
This incident affected: Good Grants application.